Mi controlador arduino se queda bloqueado

Tema en 'Mi Controlador' iniciado por Joiba, 9 Jul 2013.

  1. Joiba

    Joiba

    Mensajes:
    148
    Registrado:
    5 Feb 2008
    Ubicación:
    España
    Vale, ya esta copilado y probando, haber si no se queda bloqueado ahora, espero que sea del anterior codigo.
     
  2. isoriano

    isoriano

    Mensajes:
    353
    Registrado:
    12 Sep 2011
    Ubicación:
    badalona
    esperemos que no se cuengue si lo hace me huele a que tu arduino tiene algun problema pero no lo sabremos seguro asta
    1 que yo ponga en marcha mi arduino y prueve el codigo de conan
    2 que realmente tu arduino tenga algun defecto i por eso falle
    3 si es el codigo entre los dos y la ayuda de los compañeros temdremos que acabar el codigo que e expuesto aqui y hacerlo total mete operativo

    por cierto ya funciona el foro otra vez jajaja
     
    Última edición: 14 Jul 2013
  3. isoriano

    isoriano

    Mensajes:
    353
    Registrado:
    12 Sep 2011
    Ubicación:
    badalona
    haber si algun compañero nos ayuda a solucionar el tema de los reles
     
  4. Joiba

    Joiba

    Mensajes:
    148
    Registrado:
    5 Feb 2008
    Ubicación:
    España
    Bueno pues parece que no es cosa del codigo, alguna idea mas para intentar solucionar el tema???
     
  5. GABO-ARG

    GABO-ARG

    Mensajes:
    1
    Registrado:
    19 May 2016
    Ubicación:
    ARGENTINA
    Hola isoriano, seguramente ya resolviste el problema ya que paso mucho tiempo, igualmente hago comentario pàra tratar de ayudar a quien hoy tenga un problema parecido.

    el problema es con el ldc con adaptador I2C, el protocolo este si pierde un dato se queda esperando eternamente hasta recibirlo y es así que parece que el arduino "se cuelga" en realidad se queda estancado esperando respuesta por el i2c, por experiencia propia el problema es con el ruido electromagnético de los relay, por mas que sean optocoplados se cuela igual, se puede solucionar usando cable mayado hasta el lcd (sda y scl) también podes poner las resistencias pull up (que algo ayudan) 4k7 a vcc o menos, y por ultimo después de accionar o liberar u relay nunca imprimir hacer un delay de 1seg asi no hay ruido fem junto durante la transmisión I2C.

    Espero poder ayudar a alguien, seria útil que comentes como resolviste finalmente el problema!

    Saludos!!